Banner
MW2019 M4A1 Extras
Thumbnail
Downloads1,657
Views5,121
Publish Date1 year ago
Last Updated1 year ago
Version1.02
Members
Tags
Avatar

tried to use this mod recently and as Taske_Akai said, crashing on startup
i have weaponlib installed, haven't tried to uninstall other mods but im sure something is just fucked up in the code, but i wouldn'tve known ¯_(ツ)_/¯
(removed some parts to shorten the crashlog)

Application has crashed: C++ exception
...ides/MW2019 M4A1 Extras/hooks/weaponfactorytweakdata.lua:4: attempt to index field 'wpn_fps_ass_mike4_barrel' (a nil value)



SCRIPT STACK

init() @mods/base/req/core/Hooks.lua:269
new() core/lib/utils/coreclass.lua:35
original() lib/tweak_data/weapontweakdata.lua:7782
_init_data_player_weapons() @mods/base/req/core/Hooks.lua:262
original() lib/tweak_data/weapontweakdata.lua:44
old_init() @mods/base/req/core/Hooks.lua:262
old_init() @mods/Bipods That Work/weapontweak.lua:4
init() @mods/Improved weapon modification/Tweak.lua:4
new() core/lib/utils/coreclass.lua:35
init() lib/tweak_data/tweakdata.lua:544
new() core/lib/utils/coreclass.lua:35
lib/tweak_data/tweakdata.lua:3592
require() =[C]
OrigRequire() @mods/base/base.lua:196
require() @mods/BeardLib/Core.lua:384
lib/setups/setup.lua:37
require() =[C]
OrigRequire() @mods/base/base.lua:196
require() @mods/BeardLib/Core.lua:384
lib/setups/menusetup.lua:1
require() =[C]
OrigRequire() @mods/base/base.lua:196
require() @mods/BeardLib/Core.lua:384
lib/entry.lua:13
require() =[C]
OrigRequire() @mods/base/base.lua:196
require() @mods/BeardLib/Core.lua:384
core/lib/coreentry.lua:19


-------------------------------

Current thread: Main
Script stack:
                        init()  @mods/base/req/core/Hooks.lua:269                   
                         new()  core/lib/utils/coreclass.lua:35                     
                    original()  lib/tweak_data/weapontweakdata.lua:7782             
   _init_data_player_weapons()  @mods/base/req/core/Hooks.lua:262                   
                    original()  lib/tweak_data/weapontweakdata.lua:44               
                    old_init()  @mods/base/req/core/Hooks.lua:262                   
                    old_init()  @mods/Bipods                                        
                                That                                                
        Work/weapontweak.lua:4  init()                                              
                @mods/Improved                                                      
                        weapon  modification/Tweak.lua:4                            
                         new()  core/lib/utils/coreclass.lua:35                     
                        init()  lib/tweak_data/tweakdata.lua:544                    
                         new()  core/lib/utils/coreclass.lua:35                     
                                lib/tweak_data/tweakdata.lua:3592                   
                     require()                                                      
                          =[C]  OrigRequire()                                       
                                @mods/base/base.lua:196                             
                     require()                                                      
   @mods/BeardLib/Core.lua:384  lib/setups/setup.lua:37                             
                     require()  =[C]                                                
                 OrigRequire()  @mods/base/base.lua:196                             
                     require()  @mods/BeardLib/Core.lua:384                         
                                lib/setups/menusetup.lua:1                          
                     require()                                                      
                          =[C]  OrigRequire()                                       
                                @mods/base/base.lua:196                             
                     require()                                                      
   @mods/BeardLib/Core.lua:384  lib/entry.lua:13                                    
                     require()  =[C]                                                
                 OrigRequire()  @mods/base/base.lua:196                             
                     require()  @mods/BeardLib/Core.lua:384                         
                                core/lib/coreentry.lua:19                           
Avatar

Hmm, did you uninstall the MW2019 M4A1 custom weapon, but keep the MW2019 M4 Extras for some reason?
Because, if I had to guess, the code is trying to add the various Weapon Painter blueprints to a weapon that is not installed.

(The mod itself adds stuff only to the MW2019 M4A1, not to the vanilla M4A1.
So idk why you would install this, but not the custom weapon it's meant to be used on.)

Avatar

@RJC9000 guess im pretty stupid lol ty for clearing it up

30 684