This thread has been locked.
Co-op doesn't work after installing the game
Avatar

I wanted to play with a friend, I created a lobby and he can’t join me, we tried the other way around, and I can’t join any players

Replies
Avatar
  • Do either of you have any mods installed? If so, check for mods that could be changing the matchmaking key- overhaul mods like Restoration Mod, "cheaty" mods, or tools like BeardLib Editor.
  • Do either of you have the Steam matchmaking mode enabled in your game's launch settings? If so, remove it.
Avatar

is there an option to delete all mods and download a "clean" game?

Avatar

@timofa121 There's no menu button, but it's quite easy to perform this action by hand.
Go to your PAYDAY 2 directory, where the executable is. (If you have Steam, this is the folder that Steam takes you to if you right-click it in your library and select "Browse local files".)

  • To disable all Lua mods (SuperBLT/BeardLib): Find the SuperBLT DLL file. This will either be called wsock32.dll or iphlpapi.dll. Only delete the ones in your PAYDAY 2 directory, and do not delete any other dll files. Once you do this, your mods will no longer be loaded, and will be completely ignored by the game, since you're removing the mechanism that runs them.

  • To disable all mod_overrides, find your mod_overrides folder and remove it. From the PAYDAY 2 directory, that's in assets/mod_overrides/. You can also remove each of the individual folders inside mod_overrides to disable each override individually.

It's not necessary to re-install the game, as modern PD2 mods don't "patch" the game content at all. The only thing you need to do to have a mod-less experience is to remove your mods.

Avatar

@offyerrocker Thank you very much I hope this helps

33 860