Need help with mysterious crash on startup.

Very recently, Payday 2 has been refusing to work for me, for some weird reason. I tried verifying the game cache, twice, to no effect, I tried deleting mods (both BLT mods and mods_overrides mods), as well as taking out both mod folders altogether, still to no effect. I even tried cutting out the save file in case it was something I've done breaking it - still nothing.

Payday 2 does start - I see the loading screen, the Ultimate Edition intro, the other intros, all the way up to the "Press any key to start" screen, where upon pressing any key, the game freezes for a second or two and crashes.

Here is the crash log. It looks identical every time I try, so I doubt time and amount of tries is a factor.

Application has crashed: C++ exception

[string "lib/managers/blackmarketmanager.lua"]:4316: bad argument #1 to 'pairs' (table expected, got nil)


add_crafted_weapon_blueprint_to_inventory() lib/managers/blackmarketmanager.lua:4316
on_sell_weapon() lib/managers/blackmarketmanager.lua:4335
_cleanup_blackmarket() lib/managers/blackmarketmanager.lua:7484
verify_dlc_items() lib/managers/blackmarketmanager.lua:7055
give_dlc_and_verify_blackmarket() lib/managers/dlcmanager.lua:162
func() lib/managers/dlcmanager.lua:176
dispatch() core/lib/utils/coreevent.lua:212
_on_load_sequence_complete() lib/managers/savefilemanager.lua:255
update() lib/managers/savefilemanager.lua:240
update() lib/setups/setup.lua:838
update() lib/setups/menusetup.lua:336
update() @mods/base/lua/MenuSetup.lua:6



         payday2_win32_release  (???)     ???                                                 
         payday2_win32_release  (???)     zip_get_name                                        
         payday2_win32_release  (???)     zip_get_name                                        


Current thread: Main


System information:
    Application version : 1.92.626.
    CPU : Intel® Core™ i5-7500 CPU @ 3.40GHz (2 cores); SSE; SSE2; SSE3; SSSE3; SSE4.1; SSE4.2
    DirectX : 12.0
    GPU : NVIDIA GeForce GTX 1050 Ti / nvldumd.dll[]
    Language : english
    Memory :     8157MB 212KB
    OS : 6.2.9200 () 0x300-0x1 (64 bits)
    Physics : threaded
    Renderer : DX9 threaded
    Sound : Realtek Semiconductor Corp. (Głośniki (Realtek High Definition Audio))

There's also the BLT mod loading log that shows fatal errors when loading certain mods, but as I said, Payday 2 wouldn't start even after cutting out both mods folders.

Can anyone smarter than me decrypt the mysteries of this crash log and point me to the obvious sollution?
hmm something tells me the crash relates to a missing custom stuff (most likely custom weapon) data

have you tried running the game with BLT and BeardLib ONLY?
I did just now. Same situation. Intros, any key screen, crash. Identical crash log too. Even tried with cutting the save file out, still crashes.
any mod you removed before the crash start happening?
I don't remember, last time I played Payday was two weeks ago, then I went for a week-long trip and only had a potato laptop with me, and when I came back from the trip Payday wasn't working.

Then again, if it's because I removed a weapon or a mod, why would it not work without the save file? With a clean, new game it wouldn't matter, would it?
So? Anyone got any idea what this is? Or is this dead and abandoned now?

Also here's the log from PAYDAY 2/mods/logs/. Some mods there show up as giving all caps FATAL ERRORS, but removing them doesn't help, nor did updating them manually.
I had something similar happen to me. For me, one of the configs in the saves folder was corrupted. Deleting it restored functionality.
Doesn't seem to be working for me in any capacity.

Also, do you mean the saves folder where save98.sav is, or the PAYDAY 2/mods/saves one?

In case you suffer from similar issues:

1) Disable cloud backup in the game's properties (Right click on the game in steam)
2) Go to your Steam install folder (where steam.exe is)
3) Search for 218620
4) Delete everything except for the folder with 760/remote in it's path (those are your screenshots)
5) Cut your savefile out and store it in a different folder
6) Start the game - you'll start with an empty save file
7) Place your savefile again
8) Congratulations - you have your things back.

Forum Jump:

Users browsing this thread: 1 Guest(s)