Attachment point crash
#1
Application has crashed: C++ exception

...rides/Marlin Model 1894 Custom/Hooks/weapontweakdata.lua:7: attempt to call method 'SetupAttachmentPoint' (a nil value)
[/url]






SCRIPT STACK



old_init() @mods/base/req/core/Hooks.lua:267

init() @assets/mod_overrides/Magpul PDR/hooks/anims.lua:4

new() core/lib/utils/coreclass.lua:35

init() lib/tweak_data/tweakdata.lua:531

new() core/lib/utils/coreclass.lua:35

lib/tweak_data/tweakdata.lua:2990

require() =[C]

OrigRequire() @mods/base/base.lua:151

require() @mods/BeardLib/Core.lua:215

lib/setups/setup.lua:35

require() =[C]

OrigRequire() @mods/base/base.lua:151

require() @mods/BeardLib/Core.lua:215

lib/setups/menusetup.lua:1

require() =[C]

OrigRequire() @mods/base/base.lua:151

require() @mods/BeardLib/Core.lua:215

lib/entry.lua:13

require() =[C]

OrigRequire() @mods/base/base.lua:151

require() @mods/BeardLib/Core.lua:215

core/lib/coreentry.lua:19





-------------------------------



Callstack:



         payday2_win32_release  (???)     ???                                                 

         payday2_win32_release  (???)     ???                                                 

         payday2_win32_release  (???)     ???                                                 

                      KERNEL32  (???)     BaseThreadInitThunk                                 

                         ntdll  (???)     RtlValidSecurityDescriptor                          

                         ntdll  (???)     RtlValidSecurityDescriptor                          

         payday2_win32_release  (???)     zip_get_name                                        





-------------------------------



Current thread: Main

Script stack:

                    old_init()  @mods/base/req/core/Hooks.lua:267                   

                        init()  @assets/mod_overrides/Magpul                        

                                PDR/hooks/anims.lua:4                               

                         new()                                                      

core/lib/utils/coreclass.lua:35  init()                                              

                                lib/tweak_data/tweakdata.lua:531                    

                         new()                                                      

core/lib/utils/coreclass.lua:35  lib/tweak_data/tweakdata.lua:2990                   

                     require()  =[C]                                                

                 OrigRequire()  @mods/base/base.lua:151                             

                     require()  @mods/BeardLib/Core.lua:215                         

                                lib/setups/setup.lua:35                             

                     require()                                                      

                          =[C]  OrigRequire()                                       

                                @mods/base/base.lua:151                             

                     require()                                                      

   @mods/BeardLib/Core.lua:215  lib/setups/menusetup.lua:1                          

                     require()  =[C]                                                

                 OrigRequire()  @mods/base/base.lua:151                             

                     require()  @mods/BeardLib/Core.lua:215                         

                                lib/entry.lua:13                                    

                     require()                                                      

                          =[C]  OrigRequire()                                       

                                @mods/base/base.lua:151                             

                     require()                                                      
[url=https://modworkshop.net/forumdisplay.php?fid=9]   @mods/BeardLib/Core.lua:215  core/lib/coreentry.lua:19         

Reply
#2
A lot of cpone mod (CAP included) are updated and now need to be placed on mods folder
Also if you have them on mods already but still left the old one on mod_overrides, it could cause issue
Reply
#3
ah ok got it! thanks for telling me
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)