Ongoing problems with Custom mods for Custom weapons
#1
Well I just recently was able to finally play payday 2 after not playing it for a while, and currently the problem I have is that it seems that Custom Mods for Custom Weapons is conflicting with some old weapon mods that are not updated and I can't tell which



Sun May 13 14:01:03 2018


Application has crashed: C++ exception
[string "core/lib/utils/coretable.lua"]:32: bad argument #1 to 'pairs' (table expected, got nil)



SCRIPT STACK

deep_clone() core/lib/utils/coretable.lua:32
func() @assets/mod_overrides/Custom attachments for custom weapons/Hooks/weaponfactorytweakdata.lua:8018
create_bonuses() @mods/base/req/core/Hooks.lua:267
_init_weapon_mods() lib/tweak_data/blackmarkettweakdata.lua:97
init() lib/tweak_data/blackmarkettweakdata.lua:39
new() core/lib/utils/coreclass.lua:35
init() lib/tweak_data/tweakdata.lua:578
new() core/lib/utils/coreclass.lua:35
lib/tweak_data/tweakdata.lua:2967
require() =[C]
require() @mods/base/base.lua:151
lib/setups/setup.lua:35
require() =[C]
require() @mods/base/base.lua:151
lib/setups/menusetup.lua:1
require() =[C]
require() @mods/base/base.lua:151
lib/entry.lua:13
require() =[C]
require() @mods/base/base.lua:151
core/lib/coreentry.lua:19


-------------------------------

Callstack:

         payday2_win32_release  (???)     ???                                                 
         payday2_win32_release  (???)     ???                                                 
         payday2_win32_release  (???)     ???                                                 
                      KERNEL32  (???)     BaseThreadInitThunk                                 
                         ntdll  (???)     RtlSubscribeWnfStateChangeNotification              
                         ntdll  (???)     RtlSubscribeWnfStateChangeNotification              
         payday2_win32_release  (???)     zip_get_name                                        


-------------------------------

Current thread: Main
Script stack:
                  deep_clone()  core/lib/utils/coretable.lua:32                     
                        func()  @assets/mod_overrides/Custom                        
                                attachments                                         
                           for                                                      
                        custom  weapons/Hooks/weaponfactorytweakdata.lua:8018       
              create_bonuses()  @mods/base/req/core/Hooks.lua:267                   
           _init_weapon_mods()  lib/tweak_data/blackmarkettweakdata.lua:97          
                        init()  lib/tweak_data/blackmarkettweakdata.lua:39          
                         new()  core/lib/utils/coreclass.lua:35                     
                        init()  lib/tweak_data/tweakdata.lua:578                    
                         new()  core/lib/utils/coreclass.lua:35                     
                                lib/tweak_data/tweakdata.lua:2967                   
                     require()                                                      
                          =[C]  require()                                           
                                @mods/base/base.lua:151                             
       lib/setups/setup.lua:35  require()                                           
                          =[C]  require()                                           
       @mods/base/base.lua:151                                                      
    lib/setups/menusetup.lua:1  require()                                           
                                =[C]                                                
                     require()                                                      
       @mods/base/base.lua:151  lib/entry.lua:13                                    
                     require()  =[C]                                                
                     require()  @mods/base/base.lua:151                             
                                core/lib/coreentry.lua:19                           

-------------------------------

System information:
Application version : 1.89.592
CPU : Intel® Core™ i7-6700HQ CPU @ 2.60GHz (2 cores); SSE; SSE2; SSE3; SSSE3; SSE4.1; SSE4.2
DirectX : 9.0c
GPU : NVIDIA GeForce GTX 970M / nvldumd.dll[23.21.13.8912]
Language : english
Memory :     8091MB 616KB
OS : 5.1.2600 (Service Pack 3) 0x300-0x1 (64 bits)
Physics : threaded
Renderer : DX9 threaded
Sound : CREATIVE (Speakers (Sound Blaster Recon3Di))
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)