Жалоба на загрузку
 
VELOSync™
Версия 4_beta
: 01-11-2017, 06:48 PM
MD5: 1d16ab0e06cc9cda6b479b2fef02d27c
Загрузок: 12707
Просмотров: 59945

[-]
Описание
Shortlink:
[Изображение: Cg9RIle.png]
VELOSYNC 4 BETA NotSoHot-fix 1
  • Fixed JSON issue in Czech localization file (**** you notepad.exe)
VELOSYNC 4 BETA RELEASED
A new beta has appeared! Crashes and other issues are very likely to happen, please comment your crashlogs if you experience a crash. Suggestions for changing the different speed values are also greatly appreciated.
CHANGELOG FOR VERSION 4BETA:
  • Added ping-based dynamic adjustment of husk speed, if your ping is very high, the speed will be increased, if it's low, the speed will also be kept low to make animations look better.

VELOSync resolves severe player desync by speeding up the speed at which player husks (your game client's interpretation of a player) may travel.

What is desync?
Desync is caused by players not being able to send/receive movement and position updates. After the player has received the delayed movement pattern, the husk will move according to that pattern. Since PAYDAY 2's default husk movement speed is rather slow, this may look awkward and can lead to effects such as interacting while moving. 

VELOSync increases the husk movement speed, therefore making desync much less noticable. 
Should you have extremely severe desync issues, VELOSync comes with a keybind feature (Options > Mod Options > VELOSync > Engage FastAntiDesync), which allows player husks to move up to 300 times as fast as usual for a short time period. At this speed, they literally teleport to the received player locations, this should even fix the most extreme desync in no time.


This mod requires BLT.
How to install this mod:
Put the "VELOSync" folder into "(your steam library)\common\PAYDAY 2\mods\".

Special Thanks to Speedy for using his incredible magician skills to create the logo and for making the Czech translation.
This mod is based on PocoHud3's anti-desync feature. All credit for that goes to them.


[-]
Лицензия

[-]
Оставьте комментарий
Вы должны войти на сайт прежде, чем оставлять сообщения

Сегодня, 04:35 AM
Nvm the issue was the file name (which probably included™. It's resolved now.

Сегодня, 02:31 AM
I found the problem, Wir.


Код:
{
    "name" : "VELOSync",
    "description" : "Resolve desync issues by increasing husk speeds",
    "author" : "VELOCiTY, thanks to Speedy for kek stuff and testing", -- You missed a comma at the end here. It broke the JSON.
    "version" : "4BETA",
    "hooks" : [  
        {
        "hook_id" : "lib/managers/menumanager", "script_path" : "lua/base.lua"
        },
        {
        "hook_id" : "lib/units/beings/player/huskplayermovement", "script_path" : "lua/husks.lua"
        },
        {
        "hook_id" : "lib/managers/localizationmanager", "script_path" : "lua/loc.lua"
        }
    ]
}

01-12-2017, 03:01 PM
http://pastebin.com/Gj2fKnQU

01-12-2017, 09:57 AM
Oh,sorry. it wasn't the problem with the mod. Don't care about what I said.

01-12-2017, 09:53 AM
My game is crashed after this mod is updated to new version. Can you take a look into it?(Maybe game is crashed because of mod conflict with your mod and a mod called "Less viewmodel & Camera Sway")

http://pastebin.com/B8Tn2yN9

01-11-2017, 06:53 PM
@FlamingFox
I have no other explanation for this other than a file being corrupted in some way, I suppose try redownloading the mod. Also, make sure that you don't have the old "VELOSync 3" folder.

01-11-2017, 02:47 AM
Everytime. Select it or hover it. It just kills the game.

01-08-2017, 10:34 PM
@FlamingFox
Does it occur every time you do that, or did this crash only occur once?

01-05-2017, 05:59 AM
When hitting Lua Mods in Options and hovering over Velosync, it crashes the game with this:

Код:
Wed Jan 04 22:55:18 2017


Application has crashed: access violation

-------------------------------

Callstack:

        payday2_win32_release  (???)     ???                                                


-------------------------------

Current thread: Main
Script stack:
               set_mod_info()  @mods/base/lua/MenuManager.lua:412                  
             highlight_item()  lib/managers/menu/renderers/menumodinfogui.lua:296  
             highlight_item()  core/lib/managers/menu/reference_renderer/coremenurenderer.lua:121  
                               lib/managers/menu/menurenderer.lua:206              
                           ()  =(tail                                              
                     call):-1  _call_callback()                                    
core/lib/managers/menu/coremenulogic.lua:327                                                      
core/lib/managers/menu/coremenulogic.lua:267  ()                                                  
                       =(tail  call):-1                                            
      _execute_action_queue()  core/lib/managers/menu/coremenulogic.lua:54        
                     update()  core/lib/managers/menu/coremenulogic.lua:64        
                     update()  core/lib/managers/menu/coremenumanager.lua:159      
                     update()  lib/managers/menumanagerpd2.lua:19                  
                               lib/setups/setup.lua:628                            
                           ()  =(tail                                              
                     call):-1  update()                                            
 lib/setups/menusetup.lua:288  update()                                            
@mods/base/lua/MenuSetup.lua:6                                                      
core/lib/setups/coresetup.lua:529  ()                                                  
                       =(tail  call):-1                                            

-------------------------------

System information:
    Application version : 1.61.1
    CPU : Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz (2 cores); SSE; SSE2; SSE3; SSSE3; SSE4.1; SSE4.2
    DirectX : 12.0
    GPU : NVIDIA GeForce GTX 750 Ti / nvd3dum.dll[21.21.13.7633]
    Language : @ID94cca2fdaccfc2cd@
    Memory :     8140MB 868KB
    OS : 6.2.9200 () 0x300-0x1 (64 bits)
    Physics : threaded
    Renderer : DX9 threaded
    Sound : Realtek Semiconductor Corp. (Speakers (Realtek High Definition Audio))


12-21-2016, 08:03 PM
ou new verzion coemd ill chek it

12-21-2016, 08:00 PM
nope i dotn paly in czech but qestion why o n new map desynch is thing?

12-21-2016, 04:01 PM
@THE EX-PRESIDENT (DRUG TITO)
It seems the only reason this could have happened is due to the Czech localization file being loaded. You don't play the game in Czech, do you?
If the issue persists, make sure you're using the newest version. I'll try fixing the localization file issue and upload the fix as soon as I can.

12-21-2016, 03:49 PM
 crashed: C++ exception

mods/base/req/json.lua:366: Unexpected character at Line 1 character 1:
since this update gmae was desynching or starting crashing all time

12-07-2016, 07:57 AM
And by in-game I actually mean mid-heist. :P

12-07-2016, 07:57 AM
@VELOCiTY So pimpmycar.lua was not a way to change the van skin in-game? Aw... ;_;

12-01-2016, 01:42 PM
@Zdann

The reason for this is very simple: I like to try a variety of different old scripts, but due to my overall laziness, I can never be bothered with making a new mod folder and mod.txt, so I temporarily modify my local VELOSync version to hook a specific file as needed.

Again due to my laziness and because of the fact that I really rushed the last update, I forgot to thoroughly check if there are any improper files left, resulting in "pimpmycar.lua" being distributed with the mod. I can assure you that the damage done is minimal because it is not defined in the mod.txt file, so it's not hooked into the game. I apologize for this occurrence.

11-27-2016, 10:11 PM
Is there any particular reason that a skin unlocker is bundled with this mod under 'pimpmycar.lua'?

11-19-2016, 10:51 PM
The default settings are the "recommended" settings, if you still think you have too much desync, increase the first value by 1 until you're happy with it.

11-19-2016, 03:30 PM
May I know whats the recommended settings for Velo Sync? Cause I have no idea what do adjust

11-10-2016, 06:07 PM
TL;DR no

Technically, the mod is not dependant on other people having it installed. It will work pretty much identically no matter if you're host or client.